What’s Vulnerable › Vulnerabilities
CVE-2026-92001: Apache Sling XSS: Missing parser resource limits
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-23 · updated 2026-09-30
- Weakness: CWE-776
Description
Improper restriction of recursive entity references in DTDs ('XML entity expansion') vulnerability in Apache Sling XSS. This issue affects Apache Sling XSS: before 2.4.12. Users are recommended to upgrade to version 2.4.12, which fixes the issue.
Affected products
- Apache Software Foundation Apache Sling XSS: before 2.4.12 — fixed in 2.4.12
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Sling XSS 2.4.12. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/m52jll26vc8g5jokbg0xt062o09wkghr
- http://www.openwall.com/lists/oss-security/2026/09/23/15
Get alerted when CVE-2026-92001 or the next vulnerability affects your stack