What’s Vulnerable › Vulnerabilities
CVE-2026-92099: WPGraphQL Smart Cache < 2.3.2 - Unauthenticated Persisted Query Registration and Alias Squatting
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-19 · updated 2026-09-21
- Weakness: CWE-284
Description
The WPGraphQL Smart Cache WordPress plugin before 2.3.2 does not require authorisation or validate a caller-supplied query identifier before storing a persisted query from a request, allowing unauthenticated users to publish arbitrary query documents and claim query aliases before a site's own frontend registers them.
Affected products
- WPGraphQL Smart Cache: before 2.3.2 — fixed in 2.3.2
How to fix
Upgrade to a fixed version: WPGraphQL Smart Cache 2.3.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-92099 or the next vulnerability affects your stack