What’s Vulnerable › Vulnerabilities
CVE-2026-92135
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-16 · updated 2026-09-18
- Weakness: CWE-79
Description
Jenkins Coverage Plugin 3.3358.v9487dde48783 and earlier does not validate the coverage results ID when a job configuration is submitted through the REST API, allowing attackers with Item/Configure permission to use a javascript: scheme URL as identifier, resulting in a stored cross-site scripting (XSS) vulnerability.
Affected products
- Jenkins Project Jenkins Coverage Plugin: all versions — fixed in 3.3361.v0626103a_67e6
How to fix
Upgrade to a fixed version: Jenkins Project Jenkins Coverage Plugin 3.3361.v0626103a_67e6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-92135 or the next vulnerability affects your stack