What’s Vulnerable › Vulnerabilities
CVE-2026-92370: Remote Session Access Control Bypass Leading to Remote Code Execution
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-29 · updated 2026-09-30
- Weakness: CWE-284
Description
An improper access control vulnerability in TeamViewer Full Client, Host, and related affected modules on Windows, Linux, and macOS allows an authenticated remote attacker to bypass user-configured permission settings during session establishment. By modifying access control parameters for restricted features, an attacker can perform actions that were explicitly denied by the victim's configuration. This may result in unauthorized actions and potentially lead to remote code execution on the target system.
Affected products
- TeamViewer Full Client: from 15.0 before 15.82; from 15.64.0 (Legacy Windows 7 & 8) before 15.64.8 (Legacy Windows 7 & 8); from 14.7.0 (Windows) before 14.7.48855 (Windows); from 13.2.0 (Windows) before 13.2.36230 (Windows); from 14.7.0 (Linux) before 14.7.48855 (Linux); from 13.2.0 (Linux) before 13.2.153995 (Linux) — fixed in 13.2.153994 (MacOS), 13.2.153995 (Linux), 13.2.36230 (Windows), 14.7.48855 (Linux), 14.7.48855 (MacOS), 14.7.48855 (Windows)
- TeamViewer Host: from 15.0 before 15.82; from 15.64.0 (Legacy Windows 7 & 8) before 15.64.8 (Legacy Windows 7 & 8); from 14.7.0 (Windows) before 14.7.48855 (Windows); from 13.2.0 (Windows) before 13.2.36230 (Windows); from 14.7.0 (Linux) before 14.7.48855 (Linux); from 13.2.0 (Linux) before 13.2.153995 (Linux) — fixed in 13.2.153994 (MacOS), 13.2.153995 (Linux), 13.2.36230 (Windows), 14.7.48855 (Linux), 14.7.48855 (MacOS), 14.7.48855 (Windows)
How to fix
Upgrade to a fixed version: TeamViewer Full Client 13.2.153994 (MacOS), 13.2.153995 (Linux), 13.2.36230 (Windows), 14.7.48855 (Linux); TeamViewer Host 13.2.153994 (MacOS), 13.2.153995 (Linux), 13.2.36230 (Windows), 14.7.48855 (Linux). Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-92370 or the next vulnerability affects your stack