What’s Vulnerable › Vulnerabilities
CVE-2026-92414: Apache Jackrabbit: Pre-auth hijack of cached sessions via derivable WebDAV lock tokens
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-07 · updated 2026-10-13
- Weakness: CWE-384
Description
: Session Fixation / Session Reuse across Users vulnerability in Apache Jackrabbit. Jackrabbit WebDAV server attaches a cached authenticated session on any Lock-Token/TransactionId/SubscriptionId/If-header field token match with no credential check. This issue affects Apache Jackrabbit: from 2.23.0 through 2.23.5, from 2.22.0 through 2.22.4, from 2.20.0 through 2.20.17. Users are recommended to upgrade to versions 2.23.6, 2.22.5, or 2.20.18 which fix the issue.
Affected products
- Apache Software Foundation Apache Jackrabbit: from 2.20.0 before 2.20.18; from 2.22.0 before 2.22.5; from 2.23.0 before 2.23.6 — fixed in 2.20.18, 2.22.5, 2.23.6
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Jackrabbit 2.20.18, 2.22.5, 2.23.6. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread.html/gmbsmrs2lycl9nld7rd0h1r1fc4t75qr
- http://www.openwall.com/lists/oss-security/2026/10/07/27
Get alerted when CVE-2026-92414 or the next vulnerability affects your stack