What’s Vulnerable › Vulnerabilities
CVE-2026-92415: Apache Jackrabbit: DavEx client runs Class.forName + (String)-constructor on server-controlled error bodies
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-07 · updated 2026-10-13
- Weakness: CWE-470
Description
— Use of Externally-Controlled Input to Select Classes or Code vulnerability in Apache Jackrabbit's WebDAV/Davex client. A malicious WebDAV/DavEx server, or an attacker able to intercept the connection, can cause the client to instantiate arbitrary classes from its classpath, which can lead to arbitrary file creation or truncation. Only applications that use jackrabbit-spi2dav (directly or through jackrabbit-jcr2dav) to connect to a remote repository are affected. Jackrabbit servers are not affected. Category: unsafe reflection on wire data (HIGH). This issue affects Apache Jackrabbit: from 2.23.0 through 2.23.5, from 2.22.0 through 2.22.4, from 2.20.0 through 2.20.17. Users are recommended to upgrade to versions 2.23.6, 2.22.5, or 2.20.18 which fix the issue.
Affected products
- Apache Software Foundation Apache Jackrabbit: from 2.20.0 before 2.20.18; from 2.22.0 before 2.22.5; from 2.23.0 before 2.23.6 — fixed in 2.20.18, 2.22.5, 2.23.6
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Jackrabbit 2.20.18, 2.22.5, 2.23.6. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread.html/hcrxm4jp1mtk56xb8p1dtryz7hl08kmr
- http://www.openwall.com/lists/oss-security/2026/10/07/28
Get alerted when CVE-2026-92415 or the next vulnerability affects your stack