What’s Vulnerable › Vulnerabilities
CVE-2026-92422: Meow Gallery < 5.5.5 - Unauthenticated Arbitrary Shortcode Execution via load_gallery_collection REST Route
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-20 · updated 2026-09-21
- Weakness: CWE-345
Description
The Meow Gallery WordPress plugin before 5.5.5 does not properly sanitize a user-supplied value before concatenating it into a shortcode string that it passes to the WordPress shortcode parser on a publicly reachable endpoint, allowing unauthenticated users to execute arbitrary registered shortcodes and disclose non-public gallery content.
Affected products
- Meow Gallery: before 5.5.5 — fixed in 5.5.5
How to fix
Upgrade to a fixed version: Meow Gallery 5.5.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-92422 or the next vulnerability affects your stack