What’s Vulnerable › Vulnerabilities
CVE-2026-92424: Content Egg < 11.9.0 - Contributor+ Stored XSS via Import Queue
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-30 · updated 2026-09-30
- Weakness: CWE-79
Description
The Content Egg WordPress plugin before 11.9.0 does not verify that a user running its bulk content-import feature is authorized for the import preset they select, and switches to the preset author's identity before creating the resulting post, allowing users with contributor-level access and above to store arbitrary web scripts unfiltered under a privileged user's account, executing in the context of anyone who later views that content.
Affected products
- Content Egg: before 11.9.0 — fixed in 11.9.0
How to fix
Upgrade to a fixed version: Content Egg 11.9.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-92424 or the next vulnerability affects your stack