What’s Vulnerable › Vulnerabilities
CVE-2026-92470: Missing Authorization in GitLab
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-24 · updated 2026-09-28
- Weakness: CWE-862
Description
GitLab has remediated an issue in GitLab EE affecting all versions from 18.7 before 19.2.7, 19.3 before 19.3.3, and 19.4 before 19.4.1 that under certain conditions could have allowed an authenticated user to access sensitive CI/CD variable values from debug-mode job traces through the Duo AI troubleshooting feature due to missing authorization checks.
Affected products
- GitLab: from 18.7.0 before 19.2.7; from 19.3.0 before 19.3.3; 19.4.0 — fixed in 19.2.7, 19.3.3
How to fix
Upgrade to a fixed version: GitLab 19.2.7, 19.3.3. Check the vendor advisory for mitigations.
References
- https://docs.gitlab.com/releases/patches/patch-release-gitlab-19-4-1-released/
- https://gitlab.com/gitlab-org/gitlab/-/work_items/617719
Get alerted when CVE-2026-92470 or the next vulnerability affects your stack