What’s Vulnerable › Vulnerabilities

CVE-2026-92528: Incorrect Authorization in GitLab

Description

GitLab has remediated an issue in GitLab EE affecting all versions from 16.11 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an authenticated user to approve a merge request despite having contributed commits to it, due to improper identity resolution.

Affected products

How to fix

Upgrade to a fixed version: GitLab 19.2.8, 19.3.5, 19.4.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-92528 or the next vulnerability affects your stack