What’s Vulnerable › Vulnerabilities
CVE-2026-92529: Incorrect Authorization in GitLab
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-24 · updated 2026-09-28
- Weakness: CWE-863
Description
GitLab has remediated an issue in GitLab EE affecting all versions from 19.1 before 19.2.7, 19.3 before 19.3.3, and 19.4 before 19.4.1 that under certain conditions could have allowed an authenticated user with developer-role permissions to bypass admin-configured AI tool governance controls for workflows in namespaces they do not control due to improper authorization checks.
Affected products
- GitLab: from 19.1.0 before 19.2.7; from 19.3.0 before 19.3.3; 19.4.0 — fixed in 19.2.7, 19.3.3
How to fix
Upgrade to a fixed version: GitLab 19.2.7, 19.3.3. Check the vendor advisory for mitigations.
References
- https://docs.gitlab.com/releases/patches/patch-release-gitlab-19-4-1-released/
- https://gitlab.com/gitlab-org/gitlab/-/work_items/605431
Get alerted when CVE-2026-92529 or the next vulnerability affects your stack