What’s Vulnerable › Vulnerabilities

CVE-2026-92530: Use of Less Trusted Source in GitLab

Description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.1 before 19.2.7, 19.3 before 19.3.3, and 19.4 before 19.4.1 that under certain conditions could have allowed an authenticated user to spoof merge request authorship and attribute content to arbitrary existing users on the target instance due to improper reliance on ephemeral cache state during Direct Transfer imports.

Affected products

How to fix

Upgrade to a fixed version: GitLab 19.2.7, 19.3.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-92530 or the next vulnerability affects your stack