What’s Vulnerable › Vulnerabilities
CVE-2026-9254: Command Injection Vulnerability in Parent Control of Multiple TP-Link Archer Devices
- Severity: high (CVSS 8.7 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-24 · updated 2026-10-13
- Weakness: CWE-78
Description
An unauthenticated OS command injection vulnerability exists in the parental control functionality of Archer BE800 V1, BE3600 V1, and AX75 V1 due to improper filtering and neutralization of special characters in certain parameters. A LAN-based attacker can inject arbitrary commands and execute them with root privileges. Successful exploitation may result in complete device compromise and impact the confidentiality, integrity, and availability of the affected device and network traffic.
Affected products
- TP-Link Systems Inc. Archer AX75 V1: before 1.1.6 Build 260716 — fixed in 1.1.6 Build 260716
- TP-Link Systems Inc. Archer BE3600 v1: before 1.2.6 Build 20260617 — fixed in 1.2.6 Build 20260617
- TP-Link Systems Inc. Archer BE800 v1: before 1.4.2 Build 260708 — fixed in 1.4.2 Build 260708
How to fix
Upgrade to a fixed version: TP-Link Systems Inc. Archer AX75 V1 1.1.6 Build 260716; TP-Link Systems Inc. Archer BE3600 v1 1.2.6 Build 20260617; TP-Link Systems Inc. Archer BE800 v1 1.4.2 Build 260708. Check the vendor advisory for mitigations.
References
- https://www.tp-link.com/en/support/download/archer-ax75/v1/#Firmware
- https://www.tp-link.com/en/support/download/archer-be3600/v1/#Firmware
- https://www.tp-link.com/en/support/download/archer-be800/v1/#Firmware
- https://www.tp-link.com/kr/support/download/archer-be3600/v1/#Firmware
- https://www.tp-link.com/us/support/download/archer-ax75/v1/#Firmware
- https://www.tp-link.com/us/support/download/archer-be3600/v1/#Firmware
- https://www.tp-link.com/us/support/download/archer-be800/v1/#Firmware
- https://www.tp-link.com/us/support/faq/5264/
Get alerted when CVE-2026-9254 or the next vulnerability affects your stack