What’s Vulnerable › Vulnerabilities
CVE-2026-9255: Tool Execution Without Authorization via Piped Stdin in Kiro CLI
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-22 · updated 2026-07-23
- Weakness: CWE-862
Description
Missing input source validation in the tool authorization prompt in Kiro CLI before 1.28.0 allows a local attacker to execute arbitrary tools, including shell commands, without user approval by crafting content that is piped to kiro-cli via stdin. We recommend you to upgrade to kiro-cli version 1.28.0 or later.
Affected products
- Amazon Kiro CLI: before 1.28.0 — fixed in 1.28.0
How to fix
Upgrade to a fixed version: Amazon Kiro CLI 1.28.0. Check the vendor advisory for mitigations.
References
- https://aws.amazon.com/security/security-bulletins/2026-035-aws/
- https://kiro.dev/changelog/cli/1-28/
Get alerted when CVE-2026-9255 or the next vulnerability affects your stack