What’s Vulnerable › Vulnerabilities
CVE-2026-9256: NGINX ngx_http_rewrite_module vulnerability
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-05-22 · updated 2026-08-25
- Weakness: CWE-122
Description
NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_rewrite_module module. This vulnerability exists when a rewrite directive uses a regex pattern with distinct, overlapping Perl-Compatible Regular Expression (PCRE) captures (for example, ^/((.*))$) and a replacement string that references multiple such captures (for example, $1$2) in a redirect or arguments context. An unauthenticated attacker along with conditions beyond their control can exploit this vulnerability by sending crafted HTTP requests. This may cause a heap buffer overflow in the NGINX worker process leading to a restart. Additionally, attackers can execute code on systems with Address Space Layout Randomization (ASLR) disabled or when the attacker can bypass ASLR. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- Debian Linux: 11.0
- F5 Dos: from 4.3.0 through 4.7.0; 4.9.0
- F5 NGINX Gateway Fabric: from 1.3.0 through 1.6.2; from 2.0.0 before 2.6.2 — fixed in 2.6.2
- F5 NGINX Ingress Controller: from 3.5.0 through 3.7.2; from 4.0.0 through 4.0.1; from 5.0.0 before 5.4.3 — fixed in 5.4.3
- F5 NGINX Instance Manager: from 2.17.0 before 2.22.1 — fixed in 2.22.1
- F5 NGINX Open Source: from 0.1.17 through 0.9.7; from 1.0.0 before 1.30.2; 1.31.0 — fixed in 1.30.2
- F5 NGINX Plus: from r33 before r36; 37.0.0.1, r32, r32-p1, r32-p2, r32-p3, r32-p4 (+7) — fixed in r36
- F5 Waf: from 4.10.0 through 4.16.0; from 5.2.0 through 5.8.0; from 5.9.0 through 5.13.0
- RedHat Discovery: all versions
- Red Hat Enterprise Linux: 8.0, 9.0, 10.0
- RedHat Hardened Images: all versions
- RedHat Update Infrastructure: from 5.0 before 5.2 — fixed in 5.2
How to fix
Upgrade to a fixed version: F5 NGINX Gateway Fabric 2.6.2; F5 NGINX Ingress Controller 5.4.3; F5 NGINX Instance Manager 2.22.1; F5 NGINX Open Source 1.30.2; F5 NGINX Plus r36; RedHat Update Infrastructure 5.2. Check the vendor advisory for mitigations.
References
- https://my.f5.com/manage/s/article/K000161377
- http://www.openwall.com/lists/oss-security/2026/05/22/14
- https://lists.debian.org/debian-lts-announce/2026/06/msg00023.html
- https://access.redhat.com/errata/RHSA-2026:20351
- https://access.redhat.com/errata/RHSA-2026:28212
- https://access.redhat.com/errata/RHSA-2026:28921
- https://access.redhat.com/errata/RHSA-2026:28973
- https://access.redhat.com/errata/RHSA-2026:29151
- https://access.redhat.com/errata/RHSA-2026:29874
- https://access.redhat.com/errata/RHSA-2026:33313
- https://access.redhat.com/errata/RHSA-2026:44481
- https://access.redhat.com/errata/RHSA-2026:58981
Get alerted when CVE-2026-9256 or the next vulnerability affects your stack