What’s Vulnerable › Vulnerabilities
CVE-2026-92564: Apache Qpid Broker-J: Unbounded type nesting can lead to stack overflow pre-authentication in AMQP 0-8/0-9/0-9-1 field-table processing
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-25 · updated 2026-10-05
- Weakness: CWE-674
Description
A pre-authentication attacker could leverage type nesting to cause a StackOverflowError potentially leading to denial of service. This issue affects Apache Qpid Broker-J: through 10.1.0. Users are recommended to upgrade to version 10.1.1, which fixes the issue.
Affected products
- Apache Software Foundation Apache Qpid Broker-J: before 10.1.1 — fixed in 10.1.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Qpid Broker-J 10.1.1. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/hw4jkngtkzf0dxdj9mv3z2p71mkpjvx4
- http://www.openwall.com/lists/oss-security/2026/09/24/14
Get alerted when CVE-2026-92564 or the next vulnerability affects your stack