What’s Vulnerable › Vulnerabilities
CVE-2026-9259
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-16 · updated 2026-06-18
- Weakness: CWE-295
Description
Improper validation of server certificates in Canon EOS Network Setting Tool Version 1.5.0 or earlier
Affected products
- Canon Eos Network Setting Tool: before 1.5.1 — fixed in 1.5.1
How to fix
Upgrade to a fixed version: Canon Eos Network Setting Tool 1.5.1. Check the vendor advisory for mitigations.
References
- https://canon.jp/support/support-info/260615vulnerability-response
- https://psirt.canon/advisory-information/cp2026-005/
- https://www.canon-europe.com/support/product-security/
- https://www.usa.canon.com/about-us/to-our-customers/cpa2026-005-vulnerability-remediation-for-eos-network-setting-tool
Get alerted when CVE-2026-9259 or the next vulnerability affects your stack