What’s Vulnerable › Vulnerabilities
CVE-2026-92590: Craft CMS 5.7.0 before 5.10.13 Stored XSS via Generated Fields
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-16 · updated 2026-09-22
- Weakness: CWE-79
Description
Craft CMS versions from 5.7.0 before 5.10.13 contain a stored cross-site scripting vulnerability in the Generated Fields feature that disables Twig autoescaping and fails to encode cached values. Content editors can inject malicious JavaScript through editable fields that executes in authenticated Control Panel sessions of higher-privileged users viewing element indexes.
Affected products
- craftcms cms: from 5.7.0 before 5.10.13 — fixed in 5.10.13
How to fix
Upgrade to a fixed version: craftcms cms 5.10.13. Check the vendor advisory for mitigations.
References
- https://github.com/craftcms/cms/security/advisories/GHSA-h9jh-v8vc-m5rp
- https://www.vulncheck.com/advisories/craft-cms-5.7.0-before-5.10.13-stored-xss-via-generated-fields
Get alerted when CVE-2026-92590 or the next vulnerability affects your stack