What’s Vulnerable › Vulnerabilities
CVE-2026-92596: Nodemailer before 9.1.0 Denial of Service via addressparser
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-16 · updated 2026-09-22
- Weakness: CWE-400
Description
Nodemailer before 9.1.0 contains a quadratic time complexity vulnerability in the addressparser component that allows remote attackers to cause denial of service by supplying a crafted comma-separated address list. Attackers can send a single email with a large number of addresses to block the Node.js event loop for extended periods, consuming 100% CPU and freezing the process.
Affected products
- nodemailer: before 9.1.0 — fixed in 9.1.0
How to fix
Upgrade to a fixed version: nodemailer 9.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/nodemailer/nodemailer/commit/34da642
- https://github.com/nodemailer/nodemailer/commit/7cc38af
- https://github.com/nodemailer/nodemailer/commit/83b8c48
- https://github.com/nodemailer/nodemailer/commit/9116da9
- https://github.com/nodemailer/nodemailer/security/advisories/GHSA-2x7j-588g-ccc2
- https://www.vulncheck.com/advisories/nodemailer-before-9.1.0-denial-of-service-via-addressparser
- https://github.com/nodemailer/nodemailer/security/advisories/GHSA-2x7j-588g-ccc2
Get alerted when CVE-2026-92596 or the next vulnerability affects your stack