What’s Vulnerable › Vulnerabilities
CVE-2026-92598: Nodemailer before 9.1.0 IDN/Punycode Domain Allow-list Bypass
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-16 · updated 2026-09-22
- Weakness: CWE-436
Description
Nodemailer before 9.1.0 fails to apply UTS-46 normalization when encoding international domain names, causing the domain resolver to compute a different Punycode A-label than standards-compliant parsers. Attackers can craft recipient addresses with invisible characters or compatibility mappings that pass domain allow-list checks but are delivered to attacker-controlled domains via SMTP.
Affected products
- nodemailer: before 9.1.0 — fixed in 9.1.0
How to fix
Upgrade to a fixed version: nodemailer 9.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/nodemailer/nodemailer/commit/259c32d
- https://github.com/nodemailer/nodemailer/commit/b212ac4
- https://github.com/nodemailer/nodemailer/security/advisories/GHSA-wmmp-3585-3rmp
- https://www.vulncheck.com/advisories/nodemailer-before-9.1.0-idn-punycode-domain-allow-list-bypass
- https://github.com/nodemailer/nodemailer/security/advisories/GHSA-wmmp-3585-3rmp
Get alerted when CVE-2026-92598 or the next vulnerability affects your stack