What’s Vulnerable › Vulnerabilities
CVE-2026-92611
- Severity: medium (CVSS 4.8 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-17 · updated 2026-09-18
- Weakness: CWE-863
Description
In Eclipse Ankaios versions 0.6.0 to before 1.0.4, `LogRule::matches` in the agent control-interface authorizer stops at the first wildcard pattern in a single rule instead of evaluating later entries, which can cause deny `LogRule` entries to be skipped and allow unauthorized access to another workload's logs.
Affected products
- Eclipse Foundation Eclipse Ankaios: from 0.6.0 before 1.0.4 — fixed in 1.0.4
How to fix
Upgrade to a fixed version: Eclipse Foundation Eclipse Ankaios 1.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/eclipse-ankaios/ankaios/pull/805
- https://github.com/eclipse-ankaios/ankaios/releases/tag/v1.0.4
- https://github.com/eclipse-ankaios/ankaios/security/advisories/GHSA-qcqx-hx4v-25rg
- https://gitlab.eclipse.org/security/cve-assignment/-/work_items/308
Get alerted when CVE-2026-92611 or the next vulnerability affects your stack