What’s Vulnerable › Vulnerabilities
CVE-2026-92759: SecObserve before 1.59.1 Information Disclosure via API Configuration
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-16 · updated 2026-09-24
- Weakness: CWE-522
Description
SecObserve versions before 1.59.1 contain an information disclosure vulnerability in the ApiConfigurationSerializer that fails to strip the basic_auth_password field from API configuration responses. View-only product members can retrieve the decrypted basic-auth password of configured scanner or integration service accounts through standard REST endpoints.
Affected products
- SecObserve: from 1.17.0 before 1.59.1 — fixed in 1.59.1
How to fix
Upgrade to a fixed version: SecObserve 1.59.1. Check the vendor advisory for mitigations.
References
- https://github.com/SecObserve/SecObserve
- https://github.com/SecObserve/SecObserve/blob/v1.54.0/backend/application/import_observations/api/serializers.py#L103-L119
- https://github.com/SecObserve/SecObserve/issues/4799
- https://github.com/SecObserve/SecObserve/releases/tag/v1.59.1
- https://github.com/SecObserve/SecObserve/security/advisories/GHSA-r968-78vw-jj9m
- https://www.vulncheck.com/advisories/secobserve-before-1.59.1-information-disclosure-via-api-configuration
Get alerted when CVE-2026-92759 or the next vulnerability affects your stack