What’s Vulnerable › Vulnerabilities
CVE-2026-92773: Trigger.dev before 4.6.0 GitHub App Installation Takeover
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-16 · updated 2026-09-23
- Weakness: CWE-639
Description
Trigger.dev before 4.6.0 fails to verify that an authenticated user controls a GitHub App installation before binding it to their organization. Attackers can claim another user's GitHub App installation by replaying state cookies and supplying sequential installation identifiers, gaining unauthorized access to the victim's repositories.
Affected products
- triggerdotdev trigger.dev: before 4.6.0 — fixed in 4.6.0
How to fix
Upgrade to a fixed version: triggerdotdev trigger.dev 4.6.0. Check the vendor advisory for mitigations.
References
- https://github.com/triggerdotdev/trigger.dev
- https://github.com/triggerdotdev/trigger.dev/blob/v4.5.16/apps/webapp/app/services/gitHub.server.ts
- https://github.com/triggerdotdev/trigger.dev/blob/v4.6.0/apps/webapp/app/services/gitHub.server.ts#L83-L86
- https://github.com/triggerdotdev/trigger.dev/security/advisories/GHSA-9rx3-j5hm-5f27
- https://www.vulncheck.com/advisories/trigger-dev-before-4.6.0-github-app-installation-takeover
Get alerted when CVE-2026-92773 or the next vulnerability affects your stack