What’s Vulnerable › Vulnerabilities
CVE-2026-92796: Manticore Search 27.0.0 before 28.4.4 Multi-Statement Authorization Bypass
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-16 · updated 2026-09-22
- Weakness: CWE-863
Description
Manticore Search versions 27.0.0 before 28.4.4 fail to validate permissions for all statements in multi-statement SQL requests, allowing read-only users to execute unauthorized queries. Attackers can append additional SELECT statements after the first statement to read credential tables and obtain password hashes that authenticate as administrators without plaintext recovery.
Affected products
- manticoresoftware Manticore Search: from 27.0.0 before 28.4.4 — fixed in 28.4.4
How to fix
Upgrade to a fixed version: manticoresoftware Manticore Search 28.4.4. Check the vendor advisory for mitigations.
References
- https://github.com/geo-chen/oss/blob/main/manticoresearch.md
- https://github.com/manticoresoftware/manticoresearch
- https://github.com/manticoresoftware/manticoresearch/blob/release-28.4.4/src/auth/auth_proto_mysql.cpp#L408-L418
- https://github.com/manticoresoftware/manticoresearch/issues/4706
- https://www.vulncheck.com/advisories/manticore-search-27.0.0-before-28.4.4-multi-statement-authorization-bypass
Get alerted when CVE-2026-92796 or the next vulnerability affects your stack