What’s Vulnerable › Vulnerabilities
CVE-2026-92806: phpList before 3.6.17 Cross-Site Request Forgery via massremove.php
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-16 · updated 2026-09-22
- Weakness: CWE-352
Description
phpList versions before 3.6.17 fail to validate cross-site request forgery tokens in the mass subscriber removal form handler. Attackers can induce logged-in administrators to visit crafted pages that silently delete and blacklist arbitrary subscriber addresses without authentication verification.
Affected products
- PHPList: before 3.6.17 — fixed in 3.6.17
How to fix
Upgrade to a fixed version: PHPList 3.6.17. Check the vendor advisory for mitigations.
References
- https://github.com/geo-chen/oss/blob/main/phplist3.md
- https://github.com/phpList/phplist3
- https://github.com/phpList/phplist3/blob/v3.6.16/public_html/lists/admin/massremove.php#L13-L24
- https://github.com/phpList/phplist3/blob/v3.6.17/public_html/lists/admin/massremove.php#L10
- https://www.vulncheck.com/advisories/phplist-before-3.6.17-cross-site-request-forgery-via-massremove-php
Get alerted when CVE-2026-92806 or the next vulnerability affects your stack