What’s Vulnerable › Vulnerabilities
CVE-2026-92816: ComfyUI before 0.30.0 Path Traversal via dataset save nodes
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-16 · updated 2026-09-22
- Weakness: CWE-22
Description
ComfyUI before 0.30.0 fails to sanitize folder_name input in dataset save nodes, allowing attackers to write files to arbitrary paths outside the output directory. Attackers can load a crafted workflow that writes attacker-controlled content to arbitrary locations, enabling code execution through modified startup files or package initializers.
Affected products
- Comfy-Org ComfyUI: before 0.30.0 — fixed in 0.30.0
How to fix
Upgrade to a fixed version: Comfy-Org ComfyUI 0.30.0. Check the vendor advisory for mitigations.
References
- https://github.com/Comfy-Org/ComfyUI
- https://github.com/Comfy-Org/ComfyUI/blob/v0.24.0/comfy_extras/nodes_dataset.py#L303-L318
- https://github.com/Comfy-Org/ComfyUI/blob/v0.30.0/comfy_extras/nodes_dataset.py
- https://github.com/geo-chen/oss/blob/main/ComfyUI.md
- https://www.vulncheck.com/advisories/comfyui-before-0.30.0-path-traversal-via-dataset-save-nodes
Get alerted when CVE-2026-92816 or the next vulnerability affects your stack