What’s Vulnerable › Vulnerabilities
CVE-2026-92883: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab
- Severity: high (CVSS 8.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-13 · updated 2026-10-14
- Weakness: CWE-79
Description
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.1 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an authenticated user to execute arbitrary JavaScript in the context of other users' browser sessions via a specially crafted repository, due to improper sanitization of HTML attributes in syntax-highlighted output.
Affected products
- GitLab: from 19.1.0 before 19.2.8; from 19.3.0 before 19.3.5; from 19.4.0 before 19.4.2 — fixed in 19.2.8, 19.3.5, 19.4.2
How to fix
Upgrade to a fixed version: GitLab 19.2.8, 19.3.5, 19.4.2. Check the vendor advisory for mitigations.
In the news
References
- https://docs.gitlab.com/releases/patches/patch-release-gitlab-19-4-2-released/
- https://gitlab.com/gitlab-org/gitlab/-/work_items/629523
- https://hackerone.com/reports/3936831
Get alerted when CVE-2026-92883 or the next vulnerability affects your stack