What’s Vulnerable › Vulnerabilities
CVE-2026-92936: vm2 3.11.0 before 3.11.7 Information Disclosure via Error Stack
- Severity: medium (CVSS 5.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-17 · updated 2026-09-17
- Weakness: CWE-209
Description
vm2 versions 3.11.0 through 3.11.6 leak absolute host filesystem paths to sandboxed code through error stack formatting. Attacker-supplied code can force the host-realm source transformer to throw a SyntaxError (for example by calling eval with malformed source) and then read the error's .stack property; the bridge forwards the .stack read to the host-realm formatter, bypassing the sandbox-side host-path redaction introduced for GHSA-v27g-jcqj-v8rw. The returned stack string discloses absolute paths from vm2, Node.js internals, and the embedding application's own source tree, along with host function names. Default new VM() and new NodeVM() configurations are affected without any special options, and the issue persists when string eval is disabled because the host-side transformer throws before eval is handled. The impact is information disclosure only; no code execution results. Fixed in vm2 3.11.7.
Affected products
- patriksimek vm2: from 3.11.0 before 3.11.7 — fixed in 3.11.7
How to fix
Upgrade to a fixed version: patriksimek vm2 3.11.7. Check the vendor advisory for mitigations.
References
- https://github.com/patriksimek/vm2/security/advisories/GHSA-x6m4-chr9-cg97
- https://www.vulncheck.com/advisories/vm2-3.11.0-before-3.11.7-information-disclosure-via-error-stack
- https://github.com/patriksimek/vm2/security/advisories/GHSA-x6m4-chr9-cg97
Get alerted when CVE-2026-92936 or the next vulnerability affects your stack