What’s Vulnerable › Vulnerabilities
CVE-2026-92946: vm2 before 3.11.7 Remote Code Execution via require.external
- Severity: critical (CVSS 10.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-17 · updated 2026-09-17
- Weakness: CWE-913
Description
vm2 before 3.11.7 contains a remote code execution vulnerability when require.external is enabled without an explicit require.root that excludes node_modules. Sandboxed code can require vm2's own package, instantiate an unrestricted NodeVM instance, and execute arbitrary host OS commands via child_process.
Affected products
- patriksimek vm2: before 3.11.7 — fixed in 3.11.7
How to fix
Upgrade to a fixed version: patriksimek vm2 3.11.7. Check the vendor advisory for mitigations.
References
- https://github.com/patriksimek/vm2/security/advisories/GHSA-j3hm-6rg5-mchv
- https://www.vulncheck.com/advisories/vm2-before-3.11.7-remote-code-execution-via-require-external
Get alerted when CVE-2026-92946 or the next vulnerability affects your stack