What’s Vulnerable › Vulnerabilities
CVE-2026-92950: vm2 before 3.11.7 Sandbox Escape via CLI require
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-17 · updated 2026-09-17
- Weakness: CWE-453
Description
vm2 before 3.11.7 contains a sandbox escape vulnerability in the CLI tool that allows attackers to execute arbitrary code in the host Node.js process. Attackers can supply a malicious script file to the vm2 CLI that uses require(__filename) to re-execute itself in the host realm, bypassing sandbox isolation and accessing host modules like fs and child_process.
Affected products
- patriksimek vm2: before 3.11.7 — fixed in 3.11.7
How to fix
Upgrade to a fixed version: patriksimek vm2 3.11.7. Check the vendor advisory for mitigations.
References
- https://github.com/patriksimek/vm2/security/advisories/GHSA-jxxv-8r27-vm4p
- https://www.vulncheck.com/advisories/vm2-before-3.11.7-sandbox-escape-via-cli-require
- https://github.com/patriksimek/vm2/security/advisories/GHSA-jxxv-8r27-vm4p
Get alerted when CVE-2026-92950 or the next vulnerability affects your stack