What’s Vulnerable › Vulnerabilities
CVE-2026-92958: vm2 before 3.11.7 Denylist Bypass via fs/promises
- Severity: high (CVSS 8.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-17 · updated 2026-09-18
- Weakness: CWE-269
Description
vm2 through 3.11.6 contains a builtin-module denylist bypass in NodeVM. When the embedder uses the builtin wildcard together with negative entries (e.g. require: { builtin: ['*', '-fs', '-child_process'] }), negative entries are matched by exact module name in lib/builtin.js, so -fs removes only the builtin named fs and does not remove builtin subpaths such as fs/promises. Sandboxed code can therefore call require('fs/promises') or require('node:fs/promises') and reach the promise-based filesystem API despite fs being denied; node: prefix handling is likewise inconsistent (a -node:fs/promises entry does not block require('fs/promises')). Host file creation and writing were confirmed via fsp.writeFile(), and other fs/promises operations (cp, mkdir, rename, rm, rmdir, truncate, read operations, etc.) are also reachable. This issue is fixed in vm2 3.11.7.
Affected products
- patriksimek vm2: before 3.11.7 — fixed in 3.11.7
How to fix
Upgrade to a fixed version: patriksimek vm2 3.11.7. Check the vendor advisory for mitigations.
References
- https://github.com/patriksimek/vm2/security/advisories/GHSA-6rh5-qq4q-97xh
- https://www.vulncheck.com/advisories/vm2-before-3.11.7-denylist-bypass-via-fs-promises
- https://github.com/patriksimek/vm2/security/advisories/GHSA-6rh5-qq4q-97xh
Get alerted when CVE-2026-92958 or the next vulnerability affects your stack