What’s Vulnerable › Vulnerabilities
CVE-2026-92963: vm2 before 3.11.2 Information Disclosure via Internal State
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-17 · updated 2026-09-18
- Weakness: CWE-227
Description
vm2 versions before 3.11.2 fail to properly restrict access to the VM2_INTERNAL_STATE_DO_NOT_USE_OR_PROGRAM_WILL_FAIL global variable. Attackers can access this internal state object through globalThis to retrieve sensitive sandbox internals.
Affected products
- patriksimek vm2: before 3.11.2 — fixed in 3.11.2
How to fix
Upgrade to a fixed version: patriksimek vm2 3.11.2. Check the vendor advisory for mitigations.
References
- https://github.com/patriksimek/vm2/security/advisories/GHSA-2cm2-m3w5-gp2f
- https://www.vulncheck.com/advisories/vm2-before-3.11.2-information-disclosure-via-internal-state
- https://github.com/patriksimek/vm2/security/advisories/GHSA-2cm2-m3w5-gp2f
Get alerted when CVE-2026-92963 or the next vulnerability affects your stack