What’s Vulnerable › Vulnerabilities

CVE-2026-92973: ansi2html 1.7.0a0 through 1.9.3 Cross-Site Scripting via OSC 8

Description

ansi2html versions 1.7.0a0 through 1.9.3 contain a cross-site scripting vulnerability in OSC 8 hyperlink handling that fails to validate or escape URL targets. Attackers controlling ANSI text input can inject javascript: schemes or terminate href attributes to execute arbitrary scripts in the context of pages displaying converted output.

Affected products

How to fix

Upgrade to a fixed version: pycontribs ansi2html 1.9.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2026-92973 or the next vulnerability affects your stack