What’s Vulnerable › Vulnerabilities
CVE-2026-92994: Verge3D < 4.13.1 - Unauthenticated Stored XSS via File Storage API
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-30 · updated 2026-09-30
- Weakness: CWE-79
Description
The Verge3D Publishing and E-Commerce WordPress plugin before 4.13.1 does not validate the contents of files uploaded through its file storage feature and serves them back with an attacker-controlled content type, allowing unauthenticated attackers to store a file containing malicious JavaScript that executes in the browser of any user who opens it.
Affected products
- Verge3D Publishing and E-Commerce: before 4.13.1 — fixed in 4.13.1
How to fix
Upgrade to a fixed version: Verge3D Publishing and E-Commerce 4.13.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-92994 or the next vulnerability affects your stack