What’s Vulnerable › Vulnerabilities
CVE-2026-93046: software node: Fix software_node_get_reference_args() with index -1
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-17 · updated 2026-10-19
Description
In the Linux kernel, the following vulnerability has been resolved: software node: Fix software_node_get_reference_args() with index -1 The bounds check for the index passed to software_node_get_reference_args() was failing when passed UINT_MAX, this in turn would lead to an out of bound access in the property array. Fix the bound check to also cover the UINT_MAX case.
Affected products
- Linux kernel: from 5.10.239 before 5.10.270; from 5.15.186 before 5.15.221; from 6.1.142 before 6.1.188; from 6.6.95 before 6.6.157; from 6.12.35 before 6.12.110; from 6.15.4 before 6.16 — fixed in 5.10.270, 5.15.221, 6.1.188, 6.12.110, 6.16, 6.6.157
How to fix
Upgrade to a fixed version: Linux kernel 5.10.270, 5.15.221, 6.1.188, 6.12.110. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/0631384eadebc66d92d2dd72d57a0263c3877bee
- https://git.kernel.org/stable/c/231bbc04c58f115a505bf3b668ec69ef40a1773b
- https://git.kernel.org/stable/c/4ebf96d5f834aba7f6d0397db4c421f6078171b9
- https://git.kernel.org/stable/c/6cde06887487b4febd14658c9a246616abcc0097
- https://git.kernel.org/stable/c/849076df15129e47dd8db751fa18489419ffea56
- https://git.kernel.org/stable/c/b2fa4e8c7e4a33e02e6aaa8f6df72f84cf4aed75
- https://git.kernel.org/stable/c/ba3dedcf3bd47017307595a7e54924198f018246
- https://git.kernel.org/stable/c/df5466412b362db7adfa78e3e092fe07ac6769a4
Get alerted when CVE-2026-93046 or the next vulnerability affects your stack