What’s Vulnerable › Vulnerabilities
CVE-2026-93063: wifi: iwlwifi: mei: check SAP message length before reading it
- Severity: high (CVSS 8.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-17 · updated 2026-10-19
Description
In the Linux kernel, the following vulnerability has been resolved: wifi: iwlwifi: mei: check SAP message length before reading it Verify the SAP message size is not larger than the local buffer before reading the message to avoid buffer overflow.
Affected products
- Linux kernel: from 6.1.2 before 6.1.188; from 6.0.16 before 6.1; 6.2 — fixed in 6.1, 6.1.188, 7.3
How to fix
Upgrade to a fixed version: Linux kernel 6.1, 6.1.188, 7.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/242125bbf19a2974d22f3d5025c9c14c0a4aea58
- https://git.kernel.org/stable/c/7d8cc301bcba233f31b589a45f4c1c97f2bb90d6
- https://git.kernel.org/stable/c/9c6bea89a16815688a5240dd4a74c922a92fcdc3
- https://git.kernel.org/stable/c/a4034f1cc8a422cefc519290d8e6cfb7ff773586
- https://git.kernel.org/stable/c/b90ebae632318dc2e5cd4ac96e454ec50f705579
- https://git.kernel.org/stable/c/f7f770d12e6e928006f89a59291074e5fea82886
Get alerted when CVE-2026-93063 or the next vulnerability affects your stack