What’s Vulnerable › Vulnerabilities
CVE-2026-9311: IBM WebSphere Application Server is affected by remote code execution
- Severity: critical (CVSS 9.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-01 · updated 2026-07-22
- Weakness: CWE-94
Description
IBM WebSphere Application Server 9.0, and 8.5 is vulnerable to remote code execution caused by the bypass of security controls.
Affected products
- IBM WebSphere Application Server: from 8.5.0.0 before 8.5.5.30; from 9.0.0.0 before 9.0.5.29 — fixed in 8.5.5.30, 9.0.5.29
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server 8.5.5.30, 9.0.5.29. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-9311 or the next vulnerability affects your stack