What’s Vulnerable › Vulnerabilities
CVE-2026-9318: tablib versions prior to 3.10.0 Stored XSS via HTML Export Dataset Title
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-08-12 · updated 2026-10-24
- Weakness: CWE-79
Description
tablib prior to 3.10.0 contains a stored cross-site scripting vulnerability in the HTML export functionality that allows attackers to execute arbitrary JavaScript by embedding malicious payloads in dataset titles, which are interpolated unsanitized into HTML output via the export_book method in the _html.py format handler. Attackers can rename worksheet sheets in imported files such as XLSX, ODS, XLS, or YAML with script payloads that are assigned to the Dataset title attribute and rendered unescaped inside an HTML h3 tag, leading to session hijacking, unauthorized administrative actions, and sensitive data exposure when the output is rendered in a browser.
Affected products
- Jazzband tablib: before 3.10.0 — fixed in 3.10.0
How to fix
Upgrade to a fixed version: Jazzband tablib 3.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/jazzband/tablib
- https://github.com/jazzband/tablib/pull/668
- https://github.com/jazzband/tablib/releases/tag/v3.10.0
- https://www.vulncheck.com/advisories/tablib-versions-prior-to-stored-xss-via-html-export-dataset-title
Get alerted when CVE-2026-9318 or the next vulnerability affects your stack