What’s Vulnerable › Vulnerabilities
CVE-2026-9320: IBM WebSphere Application Server and WebSphere Application Server Liberty are affected by multiple vulnerabilities
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-22 · updated 2026-06-23
- Weakness: CWE-400
Description
IBM WebSphere Application Server 9.0, and 8.5 and IBM WebSphere Application Server - Liberty 17.0.0.3 through 26.0.0.6 are vulnerable to a denial of service, caused by sending a specially-crafted request. A remote attacker could exploit this vulnerability to cause the server to consume memory resources.
Affected products
- IBM WebSphere Application Server: from 8.5.0.0 before 8.5.5.30; from 9.0.0.0 before 9.0.5.29; from 17.0.0.3 before 26.0.0.7 — fixed in 26.0.0.7, 8.5.5.30, 9.0.5.29
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server 26.0.0.7, 8.5.5.30, 9.0.5.29. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-9320 or the next vulnerability affects your stack