What’s Vulnerable › Vulnerabilities
CVE-2026-93289: OS command injection in Eufy Omni C20, Omni X10 Pro
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-24 · updated 2026-10-30
- Weakness: CWE-78
Description
The affected products are vulnerable to command injection attack that could allow an unauthenticated attacker to execute system commands during the pairing process.
Affected products
- Eufy Omni C20: before 1.4.6 — fixed in 1.4.6
- Eufy Omni X10 Pro: before 3.1.36 — fixed in 3.1.36
How to fix
Upgrade to a fixed version: Eufy Omni C20 1.4.6; Eufy Omni X10 Pro 3.1.36. Check the vendor advisory for mitigations.
References
- https://github.com/cisagov/CSAF/blob/develop/csaf_files/OT/white/2026/icsa-26-267-02.json
- https://www.cisa.gov/news-events/ics-advisories/icsa-26-267-02
Get alerted when CVE-2026-93289 or the next vulnerability affects your stack