What’s Vulnerable › Vulnerabilities
CVE-2026-93291: Improper certificate validation in Eufy Omni C20
- Severity: critical (CVSS 9.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-24 · updated 2026-10-30
- Weakness: CWE-295
Description
Omni C20 lacks proper certificate validation which could allow an attacker to perform a man-in-the-middle attack which could allow them to execute arbitrary code.
Affected products
- Eufy Omni C20: before 1.4.6 — fixed in 1.4.6
How to fix
Upgrade to a fixed version: Eufy Omni C20 1.4.6. Check the vendor advisory for mitigations.
References
- https://github.com/cisagov/CSAF/blob/develop/csaf_files/OT/white/2026/icsa-26-267-02.json
- https://www.cisa.gov/news-events/ics-advisories/icsa-26-267-02
Get alerted when CVE-2026-93291 or the next vulnerability affects your stack