What’s Vulnerable › Vulnerabilities
CVE-2026-93328: Missing Authorization in MCP Toolbox for Databases allows Arbitrary File Read and Write
- Severity: critical (CVSS 9.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-26 · updated 2026-10-26
- Weakness: CWE-22
Description
Path Traversal and Missing Authorization in cloud-storage source in Google Cloud MCP Toolbox for Databases (googleapis/mcp-toolbox) versions 1.2.0 through 1.4.0 allows an unauthenticated remote attacker to exfiltrate host files to external Google Cloud Storage buckets and overwrite arbitrary local files via crafted tool invocation parameters.
Summary
CVE-2026-93328 is a critical (CVSS 9.3) path traversal and missing authorization flaw in the cloud-storage source of Google Cloud MCP Toolbox for Databases (googleapis/mcp-toolbox). An unauthenticated remote attacker can use crafted tool invocation parameters to exfiltrate host files to external Google Cloud Storage buckets and overwrite arbitrary local files. Versions 1.2.0 through 1.4.0 are affected. There is no evidence of exploitation (not in CISA KEV, SSVC exploitation: none); upgrade to 1.5.0 to remediate.
تُعدّ CVE-2026-93328 ثغرة حرجة (CVSS 9.3) من نوع تجاوز المسار وانعدام التفويض في مصدر التخزين السحابي ضمن Google Cloud MCP Toolbox for Databases (googleapis/mcp-toolbox). يستطيع مهاجم بعيد غير مصادَق عليه استخدام معاملات استدعاء أدوات مُصمَّمة لتهريب ملفات المضيف إلى حاويات Google Cloud Storage خارجية والكتابة فوق ملفات محلية عشوائية. تتأثر الإصدارات من 1.2.0 حتى 1.4.0. لا توجد أدلة على استغلالها (ليست في CISA KEV، واستغلال SSVC: لا شيء)؛ ويجب الترقية إلى الإصدار 1.5.0 لمعالجتها.
Affected products
- Google Cloud MCP Toolbox for Databases (googleapis/mcp-toolbox): from 1.2.0 before 1.5.0 — fixed in 1.5.0
How to fix
Upgrade to a fixed version: Google Cloud MCP Toolbox for Databases (googleapis/mcp-toolbox) 1.5.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-93328 or the next vulnerability affects your stack