What’s Vulnerable › Vulnerabilities
CVE-2026-93339: Ditty < 3.1.70 Stored XSS via Layout Tag Wrapper Attribute
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-21 · updated 2026-09-25
- Weakness: CWE-79
Description
Metaphor Creations Ditty (ditty-news-ticker) before 3.1.70 contains a stored cross-site scripting vulnerability that allows authenticated users with Author-level privileges or higher to inject arbitrary HTML elements by supplying malicious wrapper attribute values in layout tags. The ditty_layout_render_tag_wrapper() function inserts caller-supplied wrapper attribute values directly as HTML element names without allowlist validation, bypassing wp_kses_post() sanitization because KSES runs at save time before layout tag attributes are resolved at render time, causing the payload to execute in the browser of any visitor viewing posts or pages embedding the affected Ditty item.
Affected products
- Ditty: before 3.1.70 — fixed in 3.1.70
How to fix
Upgrade to a fixed version: Ditty 3.1.70. Check the vendor advisory for mitigations.
References
- https://lazytitan.ro/ditty
- https://wordpress.org/plugins/ditty-news-ticker/#developers
- https://www.vulncheck.com/advisories/ditty-stored-xss-via-layout-tag-wrapper-attribute
Get alerted when CVE-2026-93339 or the next vulnerability affects your stack