What’s Vulnerable › Vulnerabilities
CVE-2026-93479: NGINX map directive and regex matching vulnerability
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-14 · updated 2026-10-29
- Weakness: CWE-122
Description
A vulnerability exists in NGINX Plus and NGINX Open Source when a map directive uses regex matching and the root directive or access log format references the map's regex capture variables before referencing the map output variable. Alternatively, the same result could be achieved by using a non-cacheable variable in a string expression under certain conditions. An unauthenticated attacker along with conditions beyond their control can exploit this vulnerability by sending crafted HTTP requests. This may cause a heap buffer overflow in the NGINX worker process leading to a restart. Additionally, attackers can execute code on systems with Address Space Layout Randomization (ASLR) disabled or when the attacker can bypass ASLR. Impact: This vulnerability may allow remote attackers to cause a denial-of-service (DoS) on the NGINX system or to possibly trigger a code execution. There is no control plane exposure; this is a data plane issue only. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 NGINX Open Source: from 1.31.2 before 1.31.7; from 1.30.0 before 1.30.6 — fixed in 1.31.7, 1.30.6
- F5 NGINX Plus: from 37.1.0 before 37.1.0.1; from 37.0.0 before 37.0.5.1; from R36; from R35; from R34; from R33 — fixed in 37.1.0.1, 37.0.5.1
How to fix
Upgrade to a fixed version: F5 NGINX Open Source 1.31.7, 1.30.6; F5 NGINX Plus 37.1.0.1, 37.0.5.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-93479 or the next vulnerability affects your stack