What’s Vulnerable › Vulnerabilities
CVE-2026-93509: Wallet System for WooCommerce 2.0.0 - 2.7.10 - Subscriber+ Wallet Balance Manipulation via Negative Transfer Amount
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-08 · updated 2026-10-08
- Weakness: CWE-20
Description
The Wallet System for WooCommerce WordPress plugin before 2.8.0 does not validate that a wallet transfer amount is positive, and computes the sender's new balance from a stale snapshot taken before crediting the recipient, allowing an authenticated attacker with Subscriber-level access to mint wallet funds for themselves or drain a specific victim's balance into their own account.
Affected products
- Wallet System for WooCommerce: from 2.0.0 before 2.8.0 — fixed in 2.8.0
How to fix
Upgrade to a fixed version: Wallet System for WooCommerce 2.8.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2026-93509 or the next vulnerability affects your stack