What’s Vulnerable › Vulnerabilities
CVE-2026-93577: Integer Overflow or Wraparound in GitLab
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-23 · updated 2026-10-31
- Weakness: CWE-190
Description
GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.2 before 19.2.7, 19.3 before 19.3.3, and 19.4 before 19.4.1 that under certain conditions could have allowed an authenticated user to execute arbitrary code on the GitLab server due to an integer overflow issue when compiling a specially crafted regular expression in a CI/CD configuration.
Affected products
- GitLab: from 19.2.0 before 19.2.7; from 19.3.0 before 19.3.3; 19.4.0 (and their updates) — fixed in 19.2.7, 19.3.3
- GitLab: from 19.2 before 19.2.7; from 19.3 before 19.3.3; from 19.4 before 19.4.1 — fixed in 19.2.7, 19.3.3, 19.4.1
How to fix
Upgrade to a fixed version: GitLab 19.2.7, 19.3.3; GitLab 19.2.7, 19.3.3, 19.4.1. Check the vendor advisory for mitigations.
References
- https://docs.gitlab.com/releases/patches/patch-release-gitlab-19-4-1-released/
- https://gitlab.com/gitlab-org/gitlab/-/work_items/629758
- https://hackerone.com/reports/3995696
- https://www.ruby-lang.org/en/news/2026/10/23/regexp-fixes-for-gitlab-cves/
Get alerted when CVE-2026-93577 or the next vulnerability affects your stack