What’s Vulnerable › Vulnerabilities
CVE-2026-93587: ImageMagick before 7.1.2-31 Policy Bypass via PCD decoder
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-18 · updated 2026-10-29
- Weakness: CWE-400
Description
ImageMagick before 7.1.2-31 and before 6.9.13-56 contains a policy bypass in the PCD (and, per the upstream advisory, CUBE and HALD) coder: when a specific command line option is supplied, the decoder does not check a configured resource limit, which can result in extra memory allocation. A local user able to pass command line options to ImageMagick can therefore exceed the intended memory policy limit, causing a limited availability impact. The issue is fixed in 7.1.2-31 and 6.9.13-56.
Affected products
- ImageMagick: before 6.9.13-56; from 7.0.0-0 before 7.1.2-31 — fixed in 6.9.13-56, 7.1.2-31
- ImageMagick: from 7.0.0 before 7.1.2-31 — fixed in 7.1.2-31
How to fix
Upgrade to a fixed version: ImageMagick 6.9.13-56, 7.1.2-31; ImageMagick 7.1.2-31. Check the vendor advisory for mitigations.
References
- https://github.com/ImageMagick/ImageMagick/security/advisories/GHSA-89wq-f8f6-2j2v
- https://www.vulncheck.com/advisories/imagemagick-before-7.1.2-31-policy-bypass-via-pcd-decoder
Get alerted when CVE-2026-93587 or the next vulnerability affects your stack