What’s Vulnerable › Vulnerabilities
CVE-2026-93592: vLLM before 0.28.0 Denial of Service via negative token ID
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2026-09-18 · updated 2026-09-28
- Weakness: CWE-129
Description
vLLM versions before 0.28.0 fail to validate the lower bound of token IDs in the /v1/embeddings and /pooling endpoints, allowing unauthenticated attackers to crash the engine by submitting negative token IDs. A single request with a negative token ID triggers a CUDA device-side assertion that poisons the GPU context, causing all subsequent requests to fail until the process restarts.
Affected products
- vllm-project vllm: before 0.28.0 — fixed in 0.28.0
How to fix
Upgrade to a fixed version: vllm-project vllm 0.28.0. Check the vendor advisory for mitigations.
References
- https://github.com/vllm-project/vllm/security/advisories/GHSA-25q3-v2hm-8vpf
- https://www.vulncheck.com/advisories/vllm-before-0.28.0-denial-of-service-via-negative-token-id
- https://github.com/vllm-project/vllm/security/advisories/GHSA-25q3-v2hm-8vpf
Get alerted when CVE-2026-93592 or the next vulnerability affects your stack