What’s Vulnerable › Vulnerabilities
CVE-2026-93597: ArcadeDB before 26.9.1 SSRF via IPv6 transition addresses
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-18 · updated 2026-09-18
- Weakness: CWE-918
Description
ArcadeDB versions before 26.9.1 fail to validate IPv6 transition addresses in the SSRF guard used by IMPORT DATABASE and server commands. Authenticated attackers can supply URLs resolving to NAT64, 6to4, or Teredo addresses embedding RFC 1918 or loopback IPv4 payloads to reach internal services and cloud metadata endpoints.
Affected products
- ArcadeData arcadedb: before 26.9.1 — fixed in 26.9.1
How to fix
Upgrade to a fixed version: ArcadeData arcadedb 26.9.1. Check the vendor advisory for mitigations.
References
- https://github.com/ArcadeData/arcadedb/security/advisories/GHSA-67m7-7w7g-mpmh
- https://www.vulncheck.com/advisories/arcadedb-before-26.9.1-ssrf-via-ipv6-transition-addresses
- https://github.com/ArcadeData/arcadedb/security/advisories/GHSA-67m7-7w7g-mpmh
Get alerted when CVE-2026-93597 or the next vulnerability affects your stack