What’s Vulnerable › Vulnerabilities
CVE-2026-93599: rustls-webpki before 0.103.13 Panic via empty BIT STRING
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-18 · updated 2026-09-22
- Weakness: CWE-191
Description
rustls-webpki through 0.103.12 (and 0.104.0-alpha releases before 0.104.0-alpha.7) contains a reachable panic in bit_string_flags() in src/der.rs. The input guard fails to reject a named-bit BIT STRING whose content is exactly [0x00] (zero padding bits and no data bytes), so raw_bits.len() - 1 underflows on the empty slice and the subsequent index operation panics (subtract-with-overflow in debug, index-out-of-bounds in release). The condition is reachable through the public API BorrowedCertRevocationList::from_der() when a CRL contains an issuingDistributionPoint extension with such an onlySomeReasons value. Exploitation requires an application that explicitly opts in to CRL revocation checking by passing RevocationOptions to verify_for_usage() and that parses CRL bytes obtained from a source the attacker can influence; the default rustls configuration, which does not use RevocationOptions, is unaffected. A crafted CRL causes a denial of service via the panic. Fixed in 0.103.13 and 0.104.0-alpha.7.
Affected products
- rustls webpki: before 0.103.13; from 0.104.0-alpha.1 before 0.104.0-alpha.7 — fixed in 0.103.13, 0.104.0-alpha.7
How to fix
Upgrade to a fixed version: rustls webpki 0.103.13, 0.104.0-alpha.7. Check the vendor advisory for mitigations.
References
- https://github.com/rustls/webpki/security/advisories/GHSA-82j2-j2ch-gfr8
- https://www.vulncheck.com/advisories/rustls-webpki-before-0.103.13-panic-via-empty-bit-string
- https://github.com/rustls/webpki/security/advisories/GHSA-82j2-j2ch-gfr8
Get alerted when CVE-2026-93599 or the next vulnerability affects your stack